Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sat Jul 22, 2017 10:47 pm
Voice Broadcast System


All times are UTC




Post new topic Reply to topic  [ 36 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: a2billing not charging calls with asterisk 1.6
PostPosted: Mon Apr 12, 2010 7:46 pm 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
Hello all,

I know that this has been discussed before and I have already read all relative posts with no luck.

The problem is that a2billing is not charging calls, does not update customer's balance and also duration 00:00 is displayed on the "call-history" page. Every other feature is working fine.

As told, I have read previous posts, php-pcntl is installed, I tried to use Agi or DeadAgi with the same results.

The only thing i haven't tried yet is an older version of asterisk.

Right now my system is (clean install) :
TrixBox 2.8.0.3
Asterisk 1.6.0.22
A2Billing 1.7 - yes, latest :)
PHP 5.2.5

Asterisk log files seem normal, I can make calls out of my configured trunk, simulator works fine, etc...

The only think I can see from the agi.log is the line saying that "[CHANNEL STATUS : -1 = There is no channel that matches SIP/5555-0000000f]"

[12/04/2010 21:26:58]:[file:a2billing.php - line:102 - uniqueid:]:[CallerID:]:[CN:]:[IDCONFIG : 1]
[12/04/2010 21:26:58]:[file:a2billing.php - line:103 - uniqueid:]:[CallerID:]:[CN:]:[MODE : standard]
[12/04/2010 21:26:58]:[file:Class.A2Billing.php - line:713 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:]:get_agi_request_parameter = 5555 ; SIP/5555-0000000f ; 1271096817.15 ; ; 358]
[12/04/2010 21:26:58]:[file:a2billing.php - line:158 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:]:[[ANSWER CALL]]
[12/04/2010 21:27:21]:[file:a2billing.php - line:189 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[[CHANNEL STATUS : 6 = Line is up]
[CREDIT : 3.92600][CREDIT MIN_CREDIT_2CALL : 0]]
[12/04/2010 21:27:21]:[file:a2billing.php - line:392 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[TARIFF ID -> 1]
[12/04/2010 21:27:35]:[file:Class.A2Billing.php - line:870 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[[CALL 2 DID]]
[12/04/2010 21:27:35]:[file:Class.A2Billing.php - line:885 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[DESTINATION ::> 302102931531]
[12/04/2010 21:27:42]:[file:Class.RateEngine.php - line:1234 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[app_callingcard: Dialing 'SIP/MYTRUNK/xxxxxxxxxxx|60|HRrL(9622000:61000:30000)' with timeout of '9622'.]
[12/04/2010 21:28:10]:[file:Class.RateEngine.php - line:1262 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[DIAL SIP/MYTRUNK/xxxxxxxxxxx|60|HRrL(9622000:61000:30000)]
[12/04/2010 21:28:10]:[file:Class.RateEngine.php - line:953 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[:[sessiontime: - id_cc_package_offer:-1 - package2apply:]]
[12/04/2010 21:28:10]:[file:Class.RateEngine.php - line:1098 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[[CC_asterisk_stop : SQL: DONE : result=1]]
[12/04/2010 21:28:10]:[file:a2billing.php - line:189 - uniqueid:1271096817.15]:[CallerID:5555]:[CN:1609116689]:[[CHANNEL STATUS : -1 = There is no channel that matches SIP/5555-0000000f]
[CREDIT : 3.92600][CREDIT MIN_CREDIT_2CALL : 0]]
[12/04/2010 21:28:10]:[CallerID:5555]:[CN:1609116689]:[[STOP - EXIT]]

If anyone has any clue about this problem with latest versions of asterisk and a2billing is very welcome to enlight me !!

fanis


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Mon Apr 12, 2010 8:35 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4064
Hi

where is your SIP peer registered, A2Billing or FreePBX, or are you using call through?

Joe


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Mon Apr 12, 2010 8:46 pm 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
jroper wrote:
Hi

where is your SIP peer registered, A2Billing or FreePBX, or are you using call through?

Joe



Hi Joe, thanks for the reply,
is registered to A2Billing and follows the A2B context.

Forgot to say that from total 25 test calls, only 2 where logged and billed successfully with duration and cost.
All others just display 00:00 duration and 0,00 cost :shock:

Haven't changed anything...

Any ideas ??

Fanis


Top
 Profile  
 
 Post subject: If the calling party hangs up first nothing is billed
PostPosted: Tue Apr 13, 2010 10:41 am 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
I'm going on myself to try to resolve the issue.

I just realized that calls are actually billed ONLY when the called party hangs up first.

If I (I'm the caller) hang up first, then nothing is logged or billed, so duration is 00:00 and cost is 0,00.

Is this helping anyone to guide me to resolve the issue ??

Thanks

Fanis


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Tue Apr 13, 2010 10:48 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4064
Hi

That is very odd, you are using deadagi, not AGI to call a2billing.php aren't you?

Joe


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Tue Apr 13, 2010 11:14 am 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
jroper wrote:
Hi

That is very odd, you are using deadagi, not AGI to call a2billing.php aren't you?

Joe


Hello Joe,

yes, actually i'm using DeadAGI, but as I mentioned in my initial post there is no change from DeadAGI to AGI.

I did the change once again (one minute ago) just to be sure and I have the same result. :(
When the called party hangs up everything is fine, when I hang up nothing is billed.

I have installed latest a2b 1.7 to trixbox 2.6 with asterisk 1.4 and all is fine.
But latest a2b 1.7 to trixbox 2.8 with asterisk 1.6 problem arises !

Thank you Joe, at least I don't feel alone here :wink:

I hope to find the solution before I get crazy.

Fanis


Top
 Profile  
 
 Post subject: If I press * then all OK
PostPosted: Tue Apr 13, 2010 12:42 pm 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
Trying to go further...

As I mentioned in my previous post when I (the caller) hung up first, then the call is not billed.

If the called party hungs up first then everything is OK.

I (the caller) tried to hung up by pressing the * key (star key) and everything gone well. The call was billed and logged successfully.
I tried this many times to ensure that it was not accidental.

So the conclusion is that when I normally hung up my softphone (or my analog phone connected to ATA) then nothing is billed.
If I press * to hung up the call, then all OK.

I wish to be an expert to undrestand why this is happening and find the solution.

Just in case... is it possible anyone to post his [a2billing] context for use with asterisk 1.6 ???

I'm using the default "extensions_a2billing_1_6.conf" came with latest a2b version.

Fanis


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Fri Apr 16, 2010 1:42 am 
Offline

Joined: Thu Apr 15, 2010 11:27 pm
Posts: 2
I am having the exact same problem with A2B1.6. Tested with the called party hanging up first and A2B computed duration and proper rates otherwise it was all zeros. Hope someone can help. Thanks.


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Fri Apr 23, 2010 2:21 am 
Offline

Joined: Thu Apr 15, 2010 11:27 pm
Posts: 2
Any update on this item? Desperate for a solution. Thanks :(


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Fri Apr 23, 2010 6:04 pm 
Offline

Joined: Tue Aug 14, 2007 2:31 pm
Posts: 9
From my side there is no solution yet.

I suggest you go for a clean install of your operating system, asterisk and latest a2b.

Personally I returned to asterisk 1.4 and I have no problem.

Regards

Fanis


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Wed Jun 23, 2010 8:12 pm 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
No solutions for this issue ?


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Sun Aug 01, 2010 12:27 pm 
Offline

Joined: Sat Sep 05, 2009 11:58 am
Posts: 20
Hello, I'm having the same problems with my installation. I've got a fresh installation of a2billing 1.7.1 and asterisk 1.6.0. There are incomplete calls logs recorded and no charge to account possibly due to call duration not recorded. This only happens when the calling party hangs up first. If the called party hangs up first the charge is done correctly and duration recorded in CDR.

Please help.. I've spoken to my host who is quite knowledgeable about asterisk and a2billing but they can't see the reason why this should be happening.

cm


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Sat Aug 21, 2010 10:07 pm 
Offline

Joined: Tue May 11, 2010 12:22 am
Posts: 2
Hello all,

I suffered today of this issue, and found the answer.

The problem is using a custom trunk with 'Local' in Elastix/Trixbox. In order to solve this issue, please add the following to your extensions_custom.conf

[extensions_custom.conf]
exten => _9.,1,Goto(a2billing,${EXTEN:1},1)

This way, everything which is dialed with 9 as a prefix will be sent directly to A2B, without using Local channels to dial: just simple and quick Goto routing.

Calls are billed correctly now, for both sides of the call.

Hope it helps

-Chris


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Sat Aug 21, 2010 10:33 pm 
Offline

Joined: Sat Sep 05, 2009 11:58 am
Posts: 20
You could also try using DeadAgi instead of Agi with your a2billing contexts..


Top
 Profile  
 
 Post subject: Re: a2billing not charging calls with asterisk 1.6
PostPosted: Mon Aug 23, 2010 2:03 pm 
Offline

Joined: Wed May 07, 2008 6:39 pm
Posts: 2
Hi,
I am having the same problem.
If I call out and hang up before the called party. There is no billing record. If the called party hangs up first everything is billed correctly.

Asterisk 1.6.0.26
Trixbox 2.8.0.4
A2Billing 1.7.1

I do have DeadAGI on all the a2billing context's

Is anybody else having this problem?

Thanks in advance
Bill


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 36 posts ]  Go to page 1, 2, 3  Next
Hosted Voice Broadcast


All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group