Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Mon Oct 15, 2018 10:35 am
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: A2Billing not billing calls correctly
PostPosted: Wed Jun 04, 2014 4:05 pm 
Offline

Joined: Wed Jun 04, 2014 3:47 pm
Posts: 1
Hello,

i've been developping a smartphone app allowing users/clients to seamlessly make callback calls.
The dialplan is as following :

[billmycall]
exten => _X.,1,NoOp(Calling ${EXTEN}) ; Answer()
exten => _X.,n,Goto(a2billing_main,${EXTEN},1))

[callback-a] ; A-Leg
exten => _X.,1,Set(CDR(accountcode)=...............)
exten => _X.,n,Set(CALLERID(all)=${destination})
exten => _X.,n,NoOp(Exten _X. => Calling ${EXTEN} and then bridging to ${CALLERID(num)})
exten => _X.,n,Goto(billmycall,${EXTEN},1)

[callback-b] ; B-Leg
exten => _X.,1,NoOp(bridging from ${CALLERID(num)} to ${EXTEN})
exten => _X.,n,Set(CDR(accountcode)=............)
exten => _X.,n,Goto((billmycall,${EXTEN},1)

The phone app sends A-Leg to callback-a context and B-Leg to callback-b context. When A-Leg answers, B-Leg is then called and Asterisk bridges both channels.
Everything works, A calls B and both can talk without problem.

The problem is on the billing side.
When the A-Leg calls through callback-a context, when the call is answered, A2Bill inserts a new row on the CDR table, with callduration 00:00:00 and SELL to 00:00:00 , so no billing is done. But the B-Leg which is called by callback-b context is correctly billed : duration is correct, value is also correct.
This results in 1 call (the A-Leg) not being billed, and thus resulting in loss of revenue.

What i have found so far is that while the A-Leg is being connected, A2Bill drops the call with no reason, and Asterisk continues to process the call until it is hangup by the user.

Both calls (A and B legs) use the same trunk (SIP), same rate card, same customer ID/Account number. I though it could some kind of simultaneous access limitation on account's configuration, but no, Simultaneous Access parameter is set correctly (Simultaneous Access = 1) and i've have double-checked by making several simultaneous calls using the same customer account and all calls are correctly billed and processed.
The only problem found is when bridging calls.

Any clues anyone?

Using :
Operation System Version : Debian GNU/Linux 7.3 (wheezy)
Asterisk Version : 1.8
PHP Version : 5.4.4-14+deb7u9
A2B DataBase Version : 2.0.7


Thanks in advance,

SC


Top
 Profile  
 
 Post subject: Re: A2Billing not billing calls correctly
PostPosted: Wed Apr 22, 2015 10:37 am 
Offline

Joined: Wed Apr 15, 2015 8:44 am
Posts: 4
Have you solved this issue? I am having similira problems.

Br


Top
 Profile  
 
 Post subject: Re: A2Billing not billing calls correctly
PostPosted: Thu Apr 23, 2015 12:21 pm 
Offline

Joined: Wed Apr 15, 2015 8:44 am
Posts: 4
Anyone? I am having the same problem here.

Br


Top
 Profile  
 
 Post subject: Re: A2Billing not billing calls correctly
PostPosted: Tue Oct 06, 2015 9:55 am 
Offline

Joined: Tue Oct 06, 2015 9:31 am
Posts: 2
You create a new idea to me.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 
Hosted Voice Broadcast


All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group