Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sun Apr 05, 2020 12:19 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: import SQL update 1.3 to 1.4 fails.
PostPosted: Tue May 13, 2008 2:02 am 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
Hi,
I have been trying to import the mysql update from 1.3 to 1.4 and every time I get an error

Error wrote:
Error

There seems to be an error in your SQL query. The MySQL server error output below, if there is any, may also help you in diagnosing the problem

ERROR: Unknown Punctuation String @ 50
STR: //
SQL:



-- add reseller field in cc_card
--DELIMITER //
--CREATE TRIGGER `after_ins_cc_card` AFTER INSERT ON `cc_card`
-- FOR EACH ROW begin
--
--
-- insert into cc_logrefill(credit,card_id,reseller_id) values(NEW.credit,NEW.id,NEW.reseller);
-- end
--//


SQL query:

-- add reseller field in cc_card --DELIMITER // --CREATE TRIGGER `after_ins_cc_card` AFTER INSERT ON `cc_card` -- FOR EACH ROW begin -- -- -- insert into cc_logrefill(credit,card_id,reseller_id) values(NEW.credit,NEW.id,NEW.reseller); -- end --//

MySQL said: Documentation
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '--CREATE TRIGGER `after_ins_cc_card` AFTER INSERT ON `cc_card`
--' at line 1


How can I fix it.


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 13, 2008 4:01 am 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
Are you using MySQL 5?


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 13, 2008 6:35 am 
Offline

Joined: Thu May 08, 2008 10:25 pm
Posts: 9
Location: Spain
Another part should be changed in the update MYSQL 1.3-> 1.4 to:

-- Support / Ticket section
CREATE TABLE cc_card_archive (
id BIGINT NOT NULL,
creationdate TIMESTAMP DEFAULT CURRENT_TIMESTAMP NOT NULL,
firstusedate TIMESTAMP,
expirationdate TIMESTAMP,
enableexpire INT DEFAULT 0,
expiredays INT DEFAULT 0,
username CHAR(50) NOT NULL,
useralias CHAR(50) NOT NULL,
uipass CHAR(50),
credit DECIMAL(15,5) DEFAULT 0 NOT NULL,
tariff INT DEFAULT 0
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin;


Cheers

Molto


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 13, 2008 12:49 pm 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
stavros wrote:
Are you using MySQL 5?

yes I am using 5.1


Top
 Profile  
 
 Post subject: No help on this one
PostPosted: Wed May 14, 2008 12:04 am 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
No one have any idea.


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 14, 2008 1:39 pm 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
stavros wrote:
Are you using MySQL 5?


yes I am using MYSQL 5.1 and still having the problem with the latest trunk can anyone tell me how the got it to work.

thanks


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 14, 2008 4:39 pm 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
we made various changes last days for support mainly!
can you give a try now and let me know if some issues remain.

I might recall the trunk is for dev so it s kind of usual that something is broken :wink:


++, Areski


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 14, 2008 5:20 pm 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
areski wrote:
we made various changes last days for support mainly!
can you give a try now and let me know if some issues remain.

I might recall the trunk is for dev so it s kind of usual that something is broken :wink:


++, Areski

Thanks for the reply. I tried with the lastest code and still not possible to import the update from 1.3 to 1.4 it fails when it tries to add the reseller field like I mention before. I am only testing the new code on a test machine. I am pointing out what I think is broken.

thanks


Top
 Profile  
 
 Post subject:
PostPosted: Wed May 14, 2008 11:03 pm 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
we tried quickly and didnt find an errors.
weird!


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 15, 2008 12:58 am 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
Are you using the mysql command line client to import the schema, or are you using something like PHPMyAdmin?


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 15, 2008 1:12 am 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
stavros wrote:
Are you using the mysql command line client to import the schema, or are you using something like PHPMyAdmin?

I was using PHPMyAdmin


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 15, 2008 1:35 am 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
I would suggest therein lies the issue. Use the documented and supported methods for installation please.


Top
 Profile  
 
 Post subject:
PostPosted: Thu May 15, 2008 3:41 am 
Offline

Joined: Thu Sep 13, 2007 12:46 pm
Posts: 254
Location: Naples, Fl ( USA )
stavros wrote:
I would suggest therein lies the issue. Use the documented and supported methods for installation please.

I am plainning on using the method suggested after I read Areski message. I t might be the problem. thanks for your help.I will post the result once I have a chance to test that.

Added after 1 hours 20 minutes:

graher01 wrote:
stavros wrote:
I would suggest therein lies the issue. Use the documented and supported methods for installation please.

I am plainning on using the method suggested after I read Areski message. I t might be the problem. thanks for your help.I will post the result once I have a chance to test that.


I am happy to report doing the update using the console it worked I tought I could do it using PHPAdmin I guess I was wrokng.


thanks you guys


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 
Voice Broadcast System


All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group