Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Tue Oct 16, 2018 4:58 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: php composer.phar update gives errors
PostPosted: Sat Nov 28, 2015 9:51 am 
Offline

Joined: Fri Nov 27, 2015 7:31 am
Posts: 10
any ideas please?



[[email protected] a2billing]# php composer.phar update
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package adodb/adodb-php could not be found in any version, there may be a typo in the package name.

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.

Read <https://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.






composer.json

{
"name": "start2billing/a2billing",
"description": "Phone billing system based on PHP",
"autoload": {
"psr-4": {
"": "src/"
}
},
"require": {
"php": ">=5.3.0",
"adodb/adodb-php": "dev-master",
"smarty/smarty": "3.*"
},
"license": "AGPL",
"authors": [
{
"name": "Areski Belaid",
"email": "[email protected]"
}
],
"minimum-stability": "dev",
"prefer-stable" : true,
"require-dev": {
"phpunit/phpunit": "4.7.*"
}
}


Top
 Profile  
 
 Post subject: Re: php composer.phar update gives errors
PostPosted: Sat Nov 28, 2015 6:41 pm 
Offline

Joined: Sat Nov 28, 2015 5:43 pm
Posts: 1
Hello,

I don't know if is the right solution but work:

on composer.json change:

"adodb/adodb-php": "dev-master",

with

"adodb/adodb-php": "dev-metacasing",

and on composer.lock change:

"version": "dev-master",

with

"version": "dev-metacasing",

This problem is present from one day, when developers of adodb change the adodb composer.json file on github:

https://github.com/ADOdb/ADOdb/commit/1 ... f8bfc50180

Regards


Top
 Profile  
 
 Post subject: Re: php composer.phar update gives errors
PostPosted: Sun Nov 29, 2015 4:40 am 
Offline

Joined: Fri Nov 27, 2015 7:31 am
Posts: 10
bakkolo wrote:
Hello,

I don't know if is the right solution but work:

on composer.json change:

"adodb/adodb-php": "dev-master",

with

"adodb/adodb-php": "dev-metacasing",

and on composer.lock change:

"version": "dev-master",

with

"version": "dev-metacasing",

This problem is present from one day, when developers of adodb change the adodb composer.json file on github:

https://github.com/ADOdb/ADOdb/commit/1 ... f8bfc50180

Regards


thanks

is error on centos but on ubuntu 14.04 it works fine


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 
Hosted Voice Broadcast


All times are UTC


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group