asterisk2billing.org
http://forum.asterisk2billing.org/

Asterisk can´t connect to A2b
http://forum.asterisk2billing.org/viewtopic.php?f=21&t=9203
Page 1 of 1

Author:  skiller [ Tue Oct 04, 2011 8:55 am ]
Post subject:  Asterisk can´t connect to A2b

Hi Guys,

my Asterisk was running as root together with A2B. For security reasons I run Asterisk now as
user "Asterisk"

I see in the Asterik CLI the call is coming in, but A2B does not handle any more the calls. I was not touching
A2billing after I set asterisk to user Asterisk. It was working prober the past years.

It looks like this:

Quote:
Registered IAX2 '7221347951' (AUTHENTICATED) at 83.xxx.xx.73:4588
-- Accepting AUTHENTICATED call from 83.xxx.xx.73:
> requested format = alaw,
> requested prefs = (alaw|ulaw|g729),
> actual format = ulaw,
> host prefs = (ulaw|alaw|gsm|g729),
> priority = mine
-- Executing [[email protected]:1] Answer("IAX2/3829635583-3861", "") in new stack
-- Executing [[email protected]:2] Wait("IAX2/3829635583-3861", "2") in new stack
-- Executing [[email protected]:3] DeadAGI("IAX2/3829635583-3861", "a2billing.php") in new stack
[2011-10-04 11:14:40] WARNING[30158]: res_agi.c:2203 deadagi_exec: Running DeadAGI on a live channel will cause problems, please use AGI
-- Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
[2011-10-04 11:14:40] ERROR[30158]: utils.c:966 ast_carefulwrite: write() returned error: Broken pipe
-- AGI Script a2billing.php completed, returning 0
-- Executing [[email protected]:4] Wait("IAX2/3829635583-3861", "2") in new stack
-- Executing [[email protected]:5] Hangup("IAX2/3829635583-3861", "") in new stack
== Spawn extension (a2billing, 00491776xxxxx, 5) exited non-zero on 'IAX2/3829635583-3861'
-- Hungup 'IAX2/3829635583-3861'


Page 1 of 1 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/