Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Tue Oct 22, 2019 5:09 pm
VoIP Billing solution


All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Rates and Customers issue
PostPosted: Fri May 08, 2009 8:25 am 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
Hi Guys,

I svned a2b 1.4 (rev. 1986) on asterisk 1.4 / centos 5.3. I an having the following problems.

1. Generate customers is not working, however single customer create is working.
2. Rates cannot be added, however if rates are loaded from a csv file (using import rates) then all works fine.
3. I have set up base currency to aud. then I created a single customer with $50 initial balance (AUD). now when I dial in it accepts the pin number but says $68 credit instead of $50, is this a known bug?

NOTE: I have also tried generating customers on demo version (provided on a2b website). it's not working there as well.

Any solutions for the above issues wuold be greatly appreciated?


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Fri May 08, 2009 1:14 pm 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
...strange, I cannot reproduce your issues on our trunk.
The same problems has been fixed beginning of the week.

About the Demo, you might see a big "RED" message saying that "this option is not available on Demo".
We have a demo mode that prevent you to generate customer and other option.

Yours,
/Areski


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Fri May 08, 2009 1:21 pm 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
i am using the following mysql version, could this be the reason ?

mysql-5.0.45-7.el5
mysql-devel-5.0.45-7.el5
php-mysql-5.2.6-jason.1
mysql-5.0.45-7.el5
mysql-server-5.0.45-7.el5
mysql-devel-5.0.45-7.el5


Cheers


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Fri May 08, 2009 1:32 pm 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
I dont think so


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Fri May 08, 2009 1:53 pm 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
what about the problem 3. a2b is telling incorrect credit when setting base currency as aud and then creating a customer. It seems it is converting the values from one currency to another.


cheers


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Fri May 08, 2009 10:04 pm 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
voipuser1400 wrote:
what about the problem 3. a2b is telling incorrect credit when setting base currency as aud and then creating a customer. It seems it is converting the values from one currency to another.
After changing base_currency, you need to update A2B exchange rates (by cron job, or from the Admin UI).


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Sat May 09, 2009 2:03 am 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
thx stavros, i updated currency from the UI & its now telling the correct credit in AUD.

Do you know any solutions to the problem 1 & 2 descriped above?

cheers


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Sat May 09, 2009 11:48 am 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
areski wrote:
...strange, I cannot reproduce your issues on our trunk.
The same problems has been fixed beginning of the week.



i looked into the log but didnt see a fix for ticket 501.

have u commited ur changes ? and in which rev. ?


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Sun May 10, 2009 11:16 pm 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
areski,

do u the answer to above question ?


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Mon May 11, 2009 12:24 am 
Offline

Joined: Fri Jan 02, 2009 7:56 pm
Posts: 49
Location: Odessa, Ukraine
Hi
Make a test system , where base currency is AUD, and currency for customer is AUD - seems it works in such way


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Mon May 18, 2009 6:37 am 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
i svned rev. 2048, edit rate is working fine now but generate customers still not working.

gives error about the number of customers is not selected. i tried selecting 1, 10 & 100 customers from the dropdown list but same error.

any ideas ?? :?:

cheers


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Mon May 18, 2009 9:18 am 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
Generate customer seems to work smoothly for me.

Rgds,
/Areski


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Tue May 19, 2009 10:47 am 
Offline
User avatar

Joined: Sat Mar 28, 2009 5:50 am
Posts: 96
its not working in ie7. which browser are you using ?


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Tue May 19, 2009 11:02 am 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
well it will be nice if you can test on Firefox so that you can report if this is only an issue on IE.

I dont have to tell you this will save us some time as we don't use IE...

Cheers,
/Areski


Top
 Profile  
 
 Post subject: Re: Rates and Customers issue
PostPosted: Tue May 19, 2009 4:28 pm 
Offline

Joined: Tue Aug 19, 2008 3:49 pm
Posts: 184
areski wrote:
well it will be nice if you can test on Firefox so that you can report if this is only an issue on IE.

I dont have to tell you this will save us some time as we don't use IE...

Cheers,
/Areski


I am a little confused about the not using IE statement. I usually do not use IE. However, most of the world still does. Based on this, I would think having the software work correctly on IE would be something you would want to achieve?

Kind Regards,
Les


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Voice Broadcast System


All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group