Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Wed Oct 17, 2018 11:26 am
VoIP Billing solution


All times are UTC




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: balance goes negative- SOLVED
PostPosted: Sun Mar 18, 2007 9:55 pm 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
this topic has been discussed before, but with no solution..

how to prevent balance from going negative. today i had a customer with -3.8 in negative balance!!!!!!!


areski please help...


Last edited by svetur on Sat Jun 02, 2007 6:16 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Wed Mar 28, 2007 11:21 pm 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
anyone, do we have anyone who's knows???? areski please help???


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 02, 2007 11:52 am 
Offline

Joined: Tue Mar 27, 2007 5:23 am
Posts: 93
Is this customer setup as Postpaid?
If so, then you also have a credit balance for him. This should be the reason why it goes negative.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 02, 2007 3:41 pm 
Offline
Moderator
User avatar

Joined: Tue Jun 06, 2006 12:14 pm
Posts: 685
Location: florida
I use something like:

dialcommand_param="|85|HL(%timeout%:60000:00000)"

for my dialing and it seems to solve the issue. Of importance is the last parameter :00000


Top
 Profile  
 
 Post subject:
PostPosted: Sat Jun 02, 2007 6:15 pm 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
Sorry i should have closed this topic earlier. krzykat is right, that works!! :D


Top
 Profile  
 
 Post subject: Balance Not Deducting from Database . . . .
PostPosted: Mon Aug 06, 2007 3:33 am 
Offline

Joined: Sun Jul 29, 2007 5:46 pm
Posts: 21
Lucky you svetur ! Atleast you have the balance being decuted. Here is my problem, I wonder if you can help me with this.

I have my a2billing setup with all the pre-requisites installed. I have setup the rates and trunks, almost everything possibly that I've could.

The ratecards, charge heads, billing blocks etc are there. There is a pin prompt and then a destination prompt after the pin is dialed.

The call is completed. I also get the warning messages from the IVR during the call, "You have 31 seconds remaining". The call is automatically dropped also when the credit limit is over.

Most amazingly, there is no deduction being done in the database. The customer's account still shows the original balance.

Any clues, why could this be happening ? For surely, the database is not being updated. The session time = 0 in the logs. When I check through the asterisk CLI while calling to my destination, I can see that time out value is correct and is exactly the same as the duration of the call.

For some reasons, the database is not being signalled or updated correctly.

One more thing. When I go into my a2billing.conf and set up the Play Menu Language = YES, the IVR does ask me to put in 1 for English and 2 for Spanish. When I press '1' for ENGLISH, there is a 2 second wait and then the call hangs up. Any bright ideas on this one ?

Any help would be greatly appreciated.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Aug 06, 2007 3:06 pm 
Offline
Moderator
User avatar

Joined: Tue Jun 06, 2006 12:14 pm
Posts: 685
Location: florida
Rehman, your issue is related to the version of Asterisk, I see that you posted all this information in another sectoin and believe you got your answer there.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Aug 07, 2007 7:14 am 
Offline

Joined: Sun Jul 29, 2007 5:46 pm
Posts: 21
The asterisk version is the same one that comes along with trixbox version 2.2. People definitely have successful implementations of a2billing with trixbox version 2.2

If you think that the asterisk version could be an issue ? What is the way out ? As per my understanding, it looks an a2billing version issue. I had my a2billing downloaded from trac.

Also, my issue still remains pending. Can you please point me a resource or a link where I can have my a2billing working in an error free mode.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Aug 07, 2007 3:18 pm 
Offline
Moderator
User avatar

Joined: Tue Jun 06, 2006 12:14 pm
Posts: 685
Location: florida
I use trix 2.2, works fine, do this ... in settings, select trixbox beta, and then upgrade your asterisk version to the 1.4 series ... I'm on 1.4.6 on mine and it works fine.


Top
 Profile  
 
 Post subject: Upgrade . .
PostPosted: Wed Aug 08, 2007 7:05 pm 
Offline

Joined: Sun Jul 29, 2007 5:46 pm
Posts: 21
Thanks again !

The update asterisk would not mess up the trixbox 2.2 , right? I remember I ran a centos update and my trixbox was behaving weird.

For asterisk update , svn checkout ? OR if you can point me a resource from where I can upgrade step by step ?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 01, 2008 4:55 pm 
Offline

Joined: Sat Jul 28, 2007 5:51 am
Posts: 79
krzykat wrote:
I use something like:

dialcommand_param="|85|HL(%timeout%:60000:00000)"

for my dialing and it seems to solve the issue. Of importance is the last parameter :00000


I just wondering if you can just not to put :00000 part there, since this is optional.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 
VoIP Billing solution


All times are UTC


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group