Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Wed Sep 18, 2019 10:11 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: A2Billing 2.0.16 Connection failed
PostPosted: Wed Feb 04, 2015 10:44 am 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
Hi all,

I'm trying to install the customer web interface on a separated server. I can acces the data base remotely from the web server with mysql console and I can see the tables. Then I asume that credentials are correct, but when I try to log into the customer web it returns " Connection failed"

The data in the /etc/a2billing.conf are correct and has the correct permissions.

Any idea ?


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Wed Feb 04, 2015 1:15 pm 
Offline

Joined: Mon Mar 02, 2009 8:56 pm
Posts: 271
I've done this a few times. As long as your DB settings are correct in /etc/a2billing.conf it should work OK.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Wed Feb 04, 2015 1:49 pm 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
I have another servers with the same settings but older versions.

The credentials in the a2billing.conf are correct. I can't that works with 2.0.16 and same settings.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Wed Feb 04, 2015 6:37 pm 
Offline

Joined: Mon Mar 02, 2009 8:56 pm
Posts: 271
From the server you are trying to install the customer portal on can you run ....

mysql -uUSER -pPASSWORD -hIP A2BILLINGDB

with the DB details from the a2billing.conf

and then run a select ...

select * from cc_sip_buddies;

That should prove remote access for the DB is OK.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Wed Feb 04, 2015 6:42 pm 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
Yes, it works and I can do a select and retrieve an answer, but the customer panel returns me connection failed.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Thu Feb 05, 2015 8:40 am 
Offline

Joined: Mon Mar 02, 2009 8:56 pm
Posts: 271
What's the exact error you get? Do you have the MySQL PHP modules on the server?


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Thu Feb 05, 2015 9:29 am 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
Yes, I have Mysql and PHP modules on the web server.

The access logs, give me OK. There aren't any errors in the error_log.

[05/Feb/2015:10:25:51 +0100] "GET /customer/ HTTP/1.1" 200 378 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome$

The error I get is Conecction Failed on the top left of the screen.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Thu Feb 05, 2015 9:43 am 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
I'm testing in localhost and the customer panel works right. But I need the web on the web Server. I don't undertand why it's not working.


Top
 Profile  
 
 Post subject: Re: A2Billing 2.0.16 Connection failed
PostPosted: Thu Feb 05, 2015 2:20 pm 
Offline

Joined: Tue Jun 22, 2010 8:37 pm
Posts: 152
SOLVED !

The problem was a missed php library for mysql.

Thanks


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 
Voice Broadcast System


All times are UTC


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group