asterisk2billing.org
http://forum.asterisk2billing.org/

a2billing.php hangups
http://forum.asterisk2billing.org/viewtopic.php?f=33&t=11857
Page 1 of 2

Author:  anovas [ Wed Oct 07, 2015 12:27 am ]
Post subject:  a2billing.php hangups

Guys, Ive been at this for weeks trying to find the cause of this error. Installed/reinstalled every combo imaginable of centOS, Ubuntu, FreePBX, PBX in a Flash and end up at the same error. Im using Amazon AWS to host my server.

Code:
[2015-10-07 00:05:40] VERBOSE[2936][C-00000004] res_agi.c: -- Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
[2015-10-07 00:05:40] VERBOSE[2936][C-00000004] res_agi.c: -- <SIP/50.22.101.14-00000004>AGI Script a2billing.php completed, returning 0
[2015-10-07 00:05:41] VERBOSE[2936][C-00000004] pbx.c: -- Executing [[email protected]:2] Hangup("SIP/50.22.101.14-00000004", "") in new stack
[2015-10-07 00:05:41] VERBOSE[2936][C-00000004] pbx.c: == Spawn extension (custom-a2billing, 14079060066, 2) exited non-zero on 'SIP/50.22.101.14-00000004


agi-bin log files are blank. Permissions I believe are all correct. The only configuration i set in A2billing is asterisk version.

Any ideas very welcome.

Thanks,

Alex

Author:  arifmouboni [ Wed Oct 07, 2015 3:46 pm ]
Post subject:  Re: a2billing.php hangups

same problem for me too. my system built on centos 6.5 with asterisk13, freepbx 13, a2billing 2.2.0. Well, its a test environment i setup to test all are working fine before putting it on production. unfortunately, i m getting same problem. a2billing.php just hangups fro every calls, agi verbose in a2bil conf does not work as i wanted to troubleshoot the issue. no cdrs generating. kind of lost where to look.

Author:  anovas [ Wed Oct 07, 2015 10:22 pm ]
Post subject:  Re: a2billing.php hangups

Ive tried asterisk 12, freebpx couple of versions also to no avail. Ubuntu 14 & CentOS 6.5, 7.0 NADA.

Author:  anovas [ Thu Oct 08, 2015 2:54 am ]
Post subject:  Re: a2billing.php hangups

Tomorrow I will try installing an older release and upgrading from there.

Author:  bucasia [ Sun Oct 11, 2015 10:59 pm ]
Post subject:  Re: a2billing.php hangups

I think because the call is getting passed to A2Billing you really need to get the a2billing logging working o see what's happening with the calls.

Like this - https://sysadminman.net/blog/2011/a2bil ... gging-2417

Author:  ziaabass [ Fri Oct 16, 2015 6:27 pm ]
Post subject:  Re: a2billing.php hangups

i have a same ishue but nothing do more i feel now help
Code:
== Using SIP RTP CoS mark 5
    -- Executing [[email protected]:1] Answer("SIP/6480252388-0000000e", "") in new stack
    -- Executing [[email protected]:2] Wait("SIP/6480252388-0000000e", "1") in new stack
    -- Executing [[email protected]:3] AGI("SIP/6480252388-0000000e", "a2billing.php,1") in new stack
    -- Launched AGI Script /usr/share/asterisk/agi-bin/a2billing.php
    -- <SIP/6480252388-0000000e>AGI Script a2billing.php completed, returning 0
    -- Executing [[email protected]:4] Hangup("SIP/6480252388-0000000e", "") in new stack
  == Spawn extension (a2billing, 00923319000256, 4) exited non-zero on 'SIP/6480252388-0000000e'
easylife*CLI>

Author:  jroper [ Mon Oct 19, 2015 9:46 am ]
Post subject:  Re: a2billing.php hangups

Hi

In the agi-conf, you can increase verbosity.

Assuming everything is installed correctly, then the main reasons for failure are:

1. Is there a rate for the destination (Check rate simulator)
2. Has customer credit (check account)
3. Are the right digits sent to the carrier (check CDR)
4. Does the number exist (ring it)
5. Is it a carrier issue. (Try another carrier)

Joe

Author:  bucasia [ Tue Oct 20, 2015 4:21 pm ]
Post subject:  Re: a2billing.php hangups

I just got caught out on a system because of the new(ish) requirements for the "vendor" folder.

If this isn't found A2Billing doesn't generate anything in the log file, you just see the "return 0". You can check this by doing something like -

su - asterisk
php /var/lib/asterisk/agi-bin/a2billing.php

Your path/user may vary. You should not see a warning about the vendor folder (you shouldn't see anything - the command should just sit there)

If you do see a warning about the vendor folder you should be able to figure out where it needs to go from the error.

Edit - Obviously this is a very specific case, Joe's general troubleshooting tips above are more likely

Author:  anovas [ Wed Oct 21, 2015 3:01 am ]
Post subject:  Re: a2billing.php hangups

I have no idea what is wrong.

logs were empty btw.

What did work was that installed 2.0.16, now I know what you guys are thinking. But it worked. Right away. Just changed the src and copied the 2.0.16 a2billing.php. I use links for all my files.

Author:  ziaabass [ Fri Oct 23, 2015 12:35 am ]
Post subject:  Re: a2billing.php hangups

bucasia wrote:
I just got caught out on a system because of the new(ish) requirements for the "vendor" folder.

If this isn't found A2Billing doesn't generate anything in the log file, you just see the "return 0". You can check this by doing something like -

su - asterisk
php /var/lib/asterisk/agi-bin/a2billing.php

Your path/user may vary. You should not see a warning about the vendor folder (you shouldn't see anything - the command should just sit there)

If you do see a warning about the vendor folder you should be able to figure out where it needs to go from the error.

Edit - Obviously this is a very specific case, Joe's general troubleshooting tips above are more likely


dear i try to php /var/lib/asterisk/agi-bin/a2billing.php
so system is show this error please tell me how to solve its

[[email protected] ~]# php /var/lib/asterisk/agi-bin/a2billing.php
PHP Fatal error: require_once(): Failed opening required '/var/lib/asterisk/agi-bin/../vendor/autoload.php' (include_path='.:/usr/share/pear:/usr/share/php') in /var/lib/asterisk/agi-bin/a2billing.php on line 42
You have new mail in /var/spool/mail/root
[[email protected] ~]#

Author:  ziaabass [ Sun Oct 25, 2015 10:20 pm ]
Post subject:  Re: a2billing.php hangups

I am waiting from 3 days please help me

Author:  bucasia [ Mon Oct 26, 2015 9:28 pm ]
Post subject:  Re: a2billing.php hangups

This file doesn't exist - /var/lib/asterisk/agi-bin/../vendor/autoload.php and it should

Maybe try ...

yum -y install mlocate
updatedb
locate autoload.php

to find out where this file is and move it to the correct location. Or you should check the installation instructions about how to install that file.

Author:  ziaabass [ Tue Oct 27, 2015 11:53 pm ]
Post subject:  Re: a2billing.php hangups

when i try to ... locate autoload.php
its show me


[[email protected] ~]# updatedb
[[email protected] ~]# locate autoload.php
/usr/local/src/a2billing/vendor/autoload.php
/usr/local/src/a2billing/vendor/phpunit/phpunit/build/phar-autoload.php.in
/usr/local/src/a2billing/vendor/sebastian/comparator/tests/autoload.php
/usr/share/php/phpDocumentor/Reflection/DocBlock/autoload.php
/var/www/html/a2billing/vendor/autoload.php
/var/www/html/a2billing/vendor/phpunit/phpunit/build/phar-autoload.php.in
/var/www/html/a2billing/vendor/sebastian/comparator/tests/autoload.php
[[email protected] ~]#

Author:  bucasia [ Wed Oct 28, 2015 9:12 am ]
Post subject:  Re: a2billing.php hangups

This should fix it ...

ln -s /var/www/html/a2billing/vendor /var/lib/asterisk/vendor

Author:  ziaabass [ Sun Nov 01, 2015 12:53 am ]
Post subject:  Re: a2billing.php hangups

thanks its working ok

Page 1 of 2 All times are UTC
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/