Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sun Dec 09, 2018 7:46 pm
Voice Broadcast System


All times are UTC




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: Updated to 1.2.3 - Signup problems
PostPosted: Wed Aug 16, 2006 9:10 am 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
Hi, i just updated to new version Braincoral. My user signup is acting out.
After i enter all the fields and submit - it freezes.
It creates new user, but it doesn't go to next page - and it doesn't send any emails???????

Any ideas.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Aug 16, 2006 12:02 pm 
Offline

Joined: Sun Mar 12, 2006 2:49 pm
Posts: 954
Location: Barcelona
did u upgrade well the DB ?
Rgds, Areski


Top
 Profile  
 
 Post subject:
PostPosted: Thu Aug 17, 2006 4:22 am 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
Hi, fixed it - manager parameters in a2billing.conf didn't mached what i had in manager.conf - that's why i got his problem.


Top
 Profile  
 
 Post subject: sign up issue
PostPosted: Sun Nov 19, 2006 7:30 am 
Offline

Joined: Sun Nov 19, 2006 7:28 am
Posts: 2
it would be nice and appreciated if you share us the fixed.. :)


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 19, 2006 6:05 pm 
Offline

Joined: Mon May 29, 2006 7:07 pm
Posts: 287
Location: Denver
a2billing.conf file

;MANAGER CONNECTION PARAMETERS
manager_host = localhost
manager_username = myasterisk
manager_secret = mycode

this should match what you have in
/etc/asterisk/manager_additional.conf

[myasterisk]
secret=mycode
deny=0.0.0.0/0.0.0.0
permit=127.0.0.1/255.255.255.0
read = system, call,log,verbose,command,agent,user
write = system, call,log,verbose,command,agent,user

You can change username and secret to anything. That fixed my problem


Top
 Profile  
 
 Post subject: sign up issue
PostPosted: Mon Nov 20, 2006 9:41 am 
Offline

Joined: Sun Nov 19, 2006 7:28 am
Posts: 2
I confirmed they matched but getting timeout error after signing up and never receives an email. My voicemail notification thru email is pretty much worin ok Im not sure the sign up doesnt. I have look and reviewed a2billing.conf unfortunately cant find a solution. I appreciate your response though..


Top
 Profile  
 
 Post subject: signup freezes
PostPosted: Mon Jan 15, 2007 2:15 am 
Offline

Joined: Fri Dec 22, 2006 2:43 pm
Posts: 76
Location: London, UK
My signup page freezes when i try to register a new customer. The user is created but it doesn't go on to the next page it just freezes and display the following message.

Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/........./lib/phpagi/phpagi-asmanager.php on line 150

in previous mail i see where someone says that the manager connection in a2billing.conf mus be the same as in manager_additional.conf.

Is this really the solution?

I ask because i do nothave this file in my /etc/asterisk directory

if it is can someone leave the contents post the contents of this page.


Top
 Profile  
 
 Post subject: Re: signup freezes
PostPosted: Mon Jan 15, 2007 3:21 am 
Offline
Moderator
User avatar

Joined: Tue Jun 06, 2006 12:14 pm
Posts: 685
Location: florida
karie_ng wrote:
Fatal error: Maximum execution time of 30 seconds exceeded in /var/www/html/........./lib/phpagi/phpagi-asmanager.php on line 150

in previous mail i see where someone says that the manager connection in a2billing.conf mus be the same as in manager_additional.conf.

Is this really the solution?


Yep - that's the real answer. Lookup prior post that tells you the setting for manager.conf , it tells you the info needed and should be your answer. It happened to me on my native trixbox install and that was the reason why.


Top
 Profile  
 
 Post subject: Re: signup freezes
PostPosted: Mon Feb 12, 2007 4:19 pm 
Offline

Joined: Mon Feb 05, 2007 6:38 am
Posts: 10
Oops ... Krzykat,


sorry,i've such a similar issue but connection parameters are OK.


When i modify one field of the Customer card (already up and working)
or just when i click on the "Confirm data" button to exit from it ...

the page seems to hang, though the modified data are registered within A2B.

This status remain for about a couple of minutes then it restarts on working again.

Have you never gt into it ?
any idea on where to look at ?

many tkx


Top
 Profile  
 
 Post subject: Finding Manager Connection Parameters
PostPosted: Sun May 06, 2007 11:23 pm 
Offline

Joined: Sun May 06, 2007 11:16 pm
Posts: 3
If you are having trouble finding the manager connection parameter section, under trix2.0 in the ets/asterisk/a2billing.conf look under the webui subsection and you will find it. Simply need to change the username & password section


Top
 Profile  
 
 Post subject: signup problem
PostPosted: Sat Jun 16, 2007 11:54 pm 
Offline

Joined: Sat May 26, 2007 9:02 am
Posts: 14
Hi Gentlemen.
I setup 1.2.3 initially so prblem doesnt relate to migration fromearly version. But I've got into the same trouble. Must to say: manager's parameters are identical in both manager.conf and a2billing.conf all the permissions for denied/allowed IPs are correct. But... customer submits form at http://MYA2BILLINGSITE/signup/index.php and scripts start to write into apache's corresponding log as follows:
[Sun Jun 17 01:10:26 2007] [error] Sun, 17 Jun 2007 01:10:26 +0300 - Unhandled response packet from Manager: Array\n(\n [Message] => Invalid/unknown command\n [Response] => Error\n)\n
[Sun Jun 17 01:10:53 2007] [error] Sun, 17 Jun 2007 01:10:53 +0300 - Got event.. registry
[Sun Jun 17 01:10:53 2007] [error] Sun, 17 Jun 2007 01:10:53 +0300 - No event handler for event 'registry'
[Sun Jun 17 01:11:39 2007] [error] Sun, 17 Jun 2007 01:11:39 +0300 - Got event.. registry
[Sun Jun 17 01:11:39 2007] [error] Sun, 17 Jun 2007 01:11:39 +0300 - No event handler for event 'registry'
[Sun Jun 17 01:12:09 2007] [error] Sun, 17 Jun 2007 01:12:09 +0300 - Got event.. peerstatus
[Sun Jun 17 01:12:09 2007] [error] Sun, 17 Jun 2007 01:12:09 +0300 - No event handler for event 'peerstatus'
Customer though is created in DB. Any other ideas about what could be a fix?

Added after 15 minutes:

Also I've found that no change is done in additional_a2billing_sip.conf though from admin pages everything works fine. Checking in a2billing.conf throu signup section gave nothing. Everything looks fine:
; SIGNUP MODULE
[signup]
; enable the signup module
enable_signup = 1
; amount of credit applied to a new user.
credit=0
; ID Tariffgroup to use, check the ID in the tariffgroup list - WebUI
tariff=4
; Specify whether the card is created as active or pending
activated=no
[blah-blah]
; Create a sip account from signup ( default : yes )
sip_account=yes
[blah-blah]
File permissions for additional_blah_blah are correct. Damn...


Top
 Profile  
 
 Post subject: Signup trouble
PostPosted: Sun Jun 17, 2007 8:59 am 
Offline

Joined: Sat May 26, 2007 9:02 am
Posts: 14
Hi there.
I've just found a mistake. It was in non standart managment port number in my *. Dont forget to check any step in chain of a2b<->* interaction :O)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 
Predictive Dialer


All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group