Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sun Apr 05, 2020 2:13 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: not getting callback in DID callback
PostPosted: Sat Nov 15, 2008 12:47 pm 
Offline

Joined: Fri Nov 14, 2008 6:49 am
Posts: 18
HI,
I am getting following error during callback testing (DID) while using all-callback extension

AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:78 - IDCONFIG : 1" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:79 - MODE : all-callback" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:91 - AGI Request:" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:92 - Array" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "(" 1>
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_request] => a2billing.php" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_channel] => SIP/204.11.194.35-098b5598" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_language] => en" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_type] => SIP" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_uniqueid] => 1226733096.45" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_callerid] => 919873375720" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_calleridname] => 919873375720" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_callingpres] => 0" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_callingani2] => 0" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_callington] => 0" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_callingtns] => 0" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_dnid] => 15168333065" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_rdnis] => unknown" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_context] => a2billing-all-callback" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_extension] => 15168333065" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_priority] => 2" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_enhanced] => 0.0" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE " [agi_accountcode] => " 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE ")" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:Class.A2Billing.php - line:622 - get_agi_request_parameter = 919873375720 ; SIP/204.11.194.35-098b5598 ; 1226733096.45 ; ; 15168333065" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:560 - [MODE : ALL-CALLBACK - 919873375720]" 1
AGI Tx >> 200 result=1
AGI Rx << VERBOSE "file:a2billing.php - line:564 - [HANGUP ALL CALLBACK TRIGGER]" 1
AGI Tx >> 200 result=1
AGI Rx << HANGUP
AGI Tx >> 200 result=1
AGI Rx << HANGUP
AGI Tx >> 200 result=1

our extensions.conf is:

[a2billing]
; CallingCard application
exten => _X.,1,Answer
exten => _X.,2,Wait,2
exten => _X.,3,DeadAGI,a2billing.php
exten => _X.,4,Wait,2
exten => _X.,5,Hangup

[a2billing-callback]
exten => _X.,1,Answer()
exten => _X.,n,DeadAGI(a2billing.php|1|callback)
exten => _X.,n,Hangup()

[a2billing-cid-callback]
exten => _X.,1,Ringing()
exten => _X.,n,Set(CALLERID(num)=${IF($[${LEN(${CALLERIDNUM})} = 10]?27:)}${CALLERIDNUM})
exten => _X.,n,DeadAGI(a2billing.php|1|cid-callback|) ;last parameter is the callback area code
exten => _X.,n,Wait(60)

[a2billing-all-callback]
exten => _X.,1,Answer()
;exten => _X.,n,Set(CALLERID(num)=${IF($[${LEN(${CALLERIDNUM})}])}${CALLERIDNUM})
exten => _X.,n,DeadAGI(a2billing.php|1|all-callback) ;last parameter is the callback area code
;exten => _X.,n,Wait(20)
exten => _X.,n,Hangup()

[a2billing-voucher]
exten => _X.,1,Set(CALLERID(num)=${IF($[${LEN(${CALLERIDNUM})} = 10]?27:)}${CALLERIDNUM})
exten => _X.,n,DeadAGI(a2billing.php|1|voucher)
exten => _X.,n,Hangup


[a2billing-did]
exten => _X.,1,DeadAGI(a2billing.php|1|did)
exten => _X.,n,Hangup

PLease suggest and correct me if I am wrong.




Regards,
Sumit


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 16, 2008 5:25 pm 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
I don't see any error messages there. Are you sure it didn't insert a call into the callback queue? Perhaps you haven't installed/launched the callback daemon.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 17, 2008 12:19 pm 
Offline

Joined: Fri Nov 14, 2008 6:49 am
Posts: 18
I installed the callback daemon and started the service but when i run the following command:

service a2billing-callback-daemon start

It starts the service but when i check

service a2billing-callback-daemon status

then it shows callback-daemon service is stopped

One more thing, In [agi-conf1] when answer_call = YES then we get the error callback hung up but when i make it answer_call = NO then i get callback is ringing but i don't get any callback.

can it be the issue with SOAP ??


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 17, 2008 12:39 pm 
Offline
Moderator
User avatar

Joined: Thu Jun 22, 2006 2:19 pm
Posts: 2890
Location: Devon, UK
Quote:
One more thing, In [agi-conf1] when answer_call = YES then we get the error callback hung up but when i make it answer_call = NO then i get callback is ringing but i don't get any callback.
Perhaps you should re-read the comments in a2billing.conf for the answer_call directive; this is expected behaviour.
Previously I asked if a callback was queued. You didn't clarify whether or not this is the case.
It's sounding likely that you don't have the callback daemon running. Try the suggestions here.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 
Predictive Dialer


All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group