Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sun Apr 05, 2020 12:47 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 1:07 pm 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
Hi, Joe

Does the 'settings in A2Billing that refer to the AMI' mean callback-server section under Admin UI?
If so, I am sure that the setting is the same as manager.conf.

And I checked full log, It seems that everything is fine.

I have the following lines in the full log file.

== Manager 'admin' logged off from 127.0.0.1
== Parsing '/etcasterisk/sipnotify.conf': [Dec 7 16:50:39] VERBOSE[3205] logger.c: == Found
== Manager 'myasterisk' logged on from 123.0.0.1



jroper wrote:
look at settings in A2Billing that refer to the AMI, and check the user, secret and host match the settings you have /etc/asterisk/manager.conf and its #includes. then go on to look at the /var/log/full log, while using the standard commands in Asterisk (type help to see these) to debug why it is not working.


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 1:09 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Weird IP address!!


== Manager 'myasterisk' logged on from 123.0.0.1


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 1:12 pm 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
Sorry, I made a mistake, should be 127.0.0.1.

:)


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 1:23 pm 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
Why is there nothing in my a2billing-daemon-callback.log?


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 3:31 pm 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
Hi, Joe

I found a post http://forum.asterisk2billing.org/viewtopic.php?f=7&t=3378&hilit=manager.

In the post you had the following:

5. Check the callback section in the gui to confirm that the asterisk manager username and password is identical to that in manager-custom.conf and the same as the manager parameters in a2billing.conf

Joe


I can't find the manager parameters in a2billing.conf.

Is that the point?


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 3:36 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Two yeas ago, when 1.3.4 current, when that post was written, the settings now found in system settings in the GUI were held in a text file called /etc/asterisk/a2billing.conf

Joe


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 8:15 pm 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
hi, Joe

My a2billing-callback context is like :

[a2billing-callback]
exten => _X.,1,DeadAGI(a2billing.php,1,callback)
exten => _X.,2,Hangup

When I changed the DeadAGI as DeadAGI(a2billing.php,1,callback,1), the Callback-Add screen show as the attachment.

I guess I go further, but still a2b does not call me back.

Do you have any idea?


Attachments:
callback-shot.jpg
callback-shot.jpg [ 115.84 KiB | Viewed 2245 times ]
Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Tue Dec 07, 2010 9:02 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Pending usually suggests the daemon is not running.

Joe


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Wed Dec 08, 2010 3:02 am 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
As for the callback daemon, it fails in the stop step (start is ok) if i restart it, while if i stop it first and then start it , it looks like no problem.

Can you figure out why? How could I check it for possible problems?

Thx, Joe.


Last edited by holyfather on Wed Dec 08, 2010 4:27 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Wed Dec 08, 2010 3:59 am 
Offline

Joined: Sat Dec 26, 2009 5:53 am
Posts: 42
I noticed that when systems start up, there are some messages sent out when initializing,

It looks like i have problems with my AMI as the messages say :

SETTING FILE PERMISSIONS
<AastraIPPhoneTextScreen>
<Text>The application cannot connect to the Asterisk Manager.Please contact your administrator.<Text>
</AastraIPPhoneTextScreen>
<AastraIPPhoneTextScreen>
<Title>Configuration error</Title>
<Text>The application cannot connect to the Asterisk Manager. Please Contact your
Administrator.</Text>
</AastraIPPhoneTextScreen>
Permissions OK
<>>Can't connect to the Asterisk Manager , please contact your administrator.


Top
 Profile  
 
 Post subject: Re: web callback problem
PostPosted: Wed Dec 08, 2010 6:47 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Hi

I cannot comment on the Aastra issues, but as I have said on many occasions, the A2B Callback Daemon MUST start after asterisk. I usually put a line in rc.local to restart the callback daemon, and create a little script to restart asterisk, and the callback daemon in the right order.

Joe


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Auto Dialer Software


All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group