Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sat Oct 21, 2017 7:29 pm
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: A couple of questions re paypal
PostPosted: Mon Oct 21, 2013 8:05 am 
Offline

Joined: Sat Dec 10, 2011 12:23 pm
Posts: 30
installed on ubuntu 12.04 LTS
asterisk 1.8
a2billing 2.0.6

Ok so I've run into what seems to be a bit of a sticking point for some, the issue is I've setup paypal and the following happens:-

1. customers can make payments and it will go into the merchant account
2. the transaction does show up in the epayment log

What happens now is the payment shows as "New" in the epayment log and the credit is not applied to the customers account.

My questions are:-

1. Is the because i'm not using ssl? If i enable ssl on the server will that resolve the problem.

I have no ssl enabled and i have nothing in the ssl sections of epayment_method

I do have 443 open back to the server (confirmed, not just guessing i do)

2. What should the status show as once the payment get applied to the customers account, proceed?

3. Why when i click on the payment in epayment log can i not update the payment at all, it just errors out with on Insert the payment method - (NUMBER FORMAT WITH/WITHOUT DECIMAL, use '.' for decimal) for payment method and Insert the owner - (NUMBER FORMAT WITH/WITHOUT DECIMAL, use '.' for decimal) for owner. Am i meant to be able to update this?

Any advice is appreciated.


Top
 Profile  
 
 Post subject: Re: A couple of questions re paypal
PostPosted: Mon Oct 21, 2013 12:24 pm 
Offline

Joined: Sat Dec 10, 2011 12:23 pm
Posts: 30
Got it sorted, was just some incorrect settings in paypal. Never really used paypal so reading through all their documentation was a bit of a chore but got there in the end.

For the record it was this:-

1. wrong API in epayment_method (still had the sandbox one in there, doh!)
2. wrong IPN address in paypal.

all the a2b settings were correct.

so for anyone else reading this, the following still work (taken from star2billings page)

https://secure.paypal.com/cgi-bin/webscr

ssl://www.paypal.com

The above was with non ssl (so port 80), i'll test with ssl later as i do have ssl enabled on the site, i just wasn't using it to get paypal working.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 
Voice Broadcast System


All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group