Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Tue Oct 24, 2017 3:44 am
Hosted Voice Broadcast


All times are UTC




Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Payment applied twice instead of once
PostPosted: Sat Nov 24, 2012 9:02 am 
Offline

Joined: Sat Nov 24, 2012 6:43 am
Posts: 4
Hi Joe,
Thanks for the quick answer!
In fact I'am not using paypal. In my case this occurs randomly when a agent add a refill to a customer account.
By the way I'am planning to upgrade to A2B 2.0 but meanwhile is there any quick fix for this bug?

Regards,


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Sat Nov 24, 2012 9:05 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4064
Hi

Can you give us step by step instructions how to replicate it?

Joe


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Sun Nov 25, 2012 4:09 pm 
Offline

Joined: Sat Nov 24, 2012 6:43 am
Posts: 4
Hi Joe,
I'am afraid that the agents who encounter the bug are hitting the browser BACK button and hitting the FORWARD button afterwards or the F5 key though they're saying they didn't.
The only way I can reproduce the bug is hitting F5 or doing a BACK/FORWARD with the browser.

Here's the logs from one agent:

XXX.XXX.XXX.XXX - user [22/Nov/2012:21:39:44 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:40:46 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?nodisplay=1&popup_select=1&popup_formname=theForm&popup_fieldname=choose_list HTTP/1.1" 200 14790
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:42:21 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=addcredit&stitle=Card_Refilled&current_page=&order=&sens=&id=45&cardnumber=enter%20cardnumber&addcredit=5&description= HTTP/1.1" 200 104011
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:43:14 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:44:58 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:45:33 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=addcredit&stitle=Card_Refilled&current_page=&order=&sens=&id=45&cardnumber=enter%20cardnumber&addcredit=5&description= HTTP/1.1" 200 104012
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:45:49 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102767
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:47:35 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102767
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:56:45 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:57:02 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:57:14 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:57:26 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:58:04 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:21:58:11 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:22:00:50 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 102766
XXX.XXX.XXX.XXX - user [22/Nov/2012:22:01:18 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 302 -
XXX.XXX.XXX.XXX - user [22/Nov/2012:22:01:37 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 302 -
XXX.XXX.XXX.XXX - user [22/Nov/2012:22:01:41 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 302 -


Here's the steps I follow to reproduce the bug:


--> Here I did a refill with the normal process:

XXX.XXX.XXX.XXX - user [25/Nov/2012:16:42:38 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?nodisplay=1&popup_select=1&popup_formname=theForm&popup_fieldname=choose_list HTTP/1.1" 200 18560
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:42:39 +0100] "GET /a2billing/agent/Public/templates/default/css/popup.css HTTP/1.1" 200 30
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:26 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=addcredit&stitle=Card_Refilled&current_page=&order=&sens=&id=33&cardnumber=enter%20cardnumber&addcredit=2&description=test%20refill%20bug HTTP/1.1" 200 117020


--> Here I hit the refresh key (F5) and the bug replicates:

XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/templates/default/css/main.css HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/templates/default/css/menu.css HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/templates/default/css/style-def.css HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/osx.css HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/jquery-1.2.6.min.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=addcredit&stitle=Card_Refilled&current_page=&order=&sens=&id=33&cardnumber=enter%20cardnumber&addcredit=2&description=test%20refill%20bug HTTP/1.1" 200 117020
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/jquery.debug.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/ilogger.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/handler_jquery.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/misc.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:38 +0100] "GET /a2billing/agent/Public/javascript/jquery/jquery.simplemodal.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/javascript/jquery/osx.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/javascript/card.js HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/house.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/plus.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/minus.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/gb.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/logout.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/br.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/fr.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/ro.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/es.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/flags/gr.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/kicons/toggle_hide2show_on.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/bg-menu-up.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/bg-menu-middle.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/bg-menu-down.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/msg_info.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/kicons/toggle_hide2show.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/kicons/pipe.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/icon_arrow_orange.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/button-search.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/info.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/user_add.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/clear.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/edit.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/delete.png HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/icon-sip.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/icon-iax.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/excel.gif HTTP/1.1" 304 -
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:43:39 +0100] "GET /a2billing/agent/Public/templates/default/images/icons_xml.gif HTTP/1.1" 304 -

--> Here I hit the browser back button twice:

XXX.XXX.XXX.XXX - user [25/Nov/2012:16:44:08 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 115745
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:44:18 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=ask-edit&id=33 HTTP/1.1" 200 115505

--> Here I hit the browser forward button twice and I the bug replicates:

XXX.XXX.XXX.XXX - user [25/Nov/2012:16:44:22 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?section=1 HTTP/1.1" 200 115745
XXX.XXX.XXX.XXX - user [25/Nov/2012:16:44:34 +0100] "GET /a2billing/agent/Public/A2B_entity_card.php?form_action=addcredit&stitle=Card_Refilled&current_page=&order=&sens=&id=33&cardnumber=enter%20cardnumber&addcredit=2&description=test%20refill%20bug HTTP/1.1" 200 117020

Although I'am not a php coder I think there should be a way to set the form data to expire or to use another tric to avoid this bug.
The scary thing is that at the beginning of this thread people are saying that they got this bug with paypal though I cannot test cause I didn't open my server to paypla yet.

Hope that this will help you. Thanks again for your king assitance.

Best Regards,


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Mon Nov 26, 2012 6:48 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4064
Hi

That would create the problems you describe.

I'll pass your comments onto Areski, the Author and developer of A2Billing.

For the moment, I can only advise that you convince your agents not to refresh the page or use the back button.

Joe


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Mon Nov 26, 2012 10:23 am 
Offline

Joined: Sat Nov 24, 2012 6:43 am
Posts: 4
Hi,
Thank you for that.
Do you know if this bug is affecting paypal too?

BR,


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Wed Nov 28, 2012 8:45 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4064
Hi

We've looked at the code, and done some tidying up, but don't see how this is possible as the payment is marked as processed. However, we will try and replicate your issue, and hopefully the logs will tell us what is going on here.

Joe


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Thu Mar 14, 2013 2:12 am 
Offline

Joined: Thu Mar 14, 2013 2:01 am
Posts: 3
Asterisk 1.8 + a2billing 2.0.1

I test with paypal sandbox and found this problem. When we have transaction marked "New" (mostly by click on order confirm and then close when it reach paypal page), and after that make other transaction successfully (mark In process and then Processed). The balance of this account will be refill twice instead of one. If this account have n transaction "New", it will add n*balace . The state of transaction still "New" but it update balance.

I don't know it's my bad configuration or about the code.

Please helpppp

Thank you


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Wed Jun 19, 2013 5:56 am 
Offline

Joined: Wed May 29, 2013 7:39 am
Posts: 7
I am using A2B 2.0.4 it is working fine except one major and big issue is with payment, When a user subscribe and user goes to paypal and pay for a subscription what ever amount he wants to pay, so from paypal the exact amount deducts what he selected but while returning back to A2B his amount is credited 4 times what he paid or deducted from paypal..

Any idea? or is this a BUG in A2B 2.0.4 version?

Thanks in adv.


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Mon Jun 24, 2013 8:14 am 
Offline

Joined: Thu Mar 14, 2013 2:01 am
Posts: 3
I got the same problem when testing a2billing with paypal sandbox. Please help....


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Tue Jun 25, 2013 3:42 am 
Offline

Joined: Thu Mar 14, 2013 2:01 am
Posts: 3
File checkout_process.php run 4 times and then, amount update 4 times for 1 payment


Top
 Profile  
 
 Post subject: Re: Payment applied twice instead of once
PostPosted: Tue Jun 25, 2013 4:47 am 
Offline

Joined: Wed May 29, 2013 7:39 am
Posts: 7
Yes, thats right..but what is the solution..Anyone knows?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Hosted Voice Broadcast


All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group