Support A2Billing :

provided by Star2Billing S.L.

Support A2Billing :
It is currently Sun Nov 19, 2017 1:07 am
VoIP Billing solution


All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: A2B 144 not answering DID calls [SOLVED]
PostPosted: Fri Jan 29, 2010 3:24 am 
Offline

Joined: Sat May 10, 2008 4:19 pm
Posts: 132
Location: Wilmington, DE
Hello All,

I just upgraded to version 1.4.4.1 and it looks good, however I'm having a few challenges that I'm sure someone could help me with.
Calls work fine when sent to a2billing,1 but whenever I send a DID to an extension, here is what happens:
Code:
[2010-01-28 22:08:20] VERBOSE[13264] logger.c: -- Goto (a2billing-did,1XXX2441026,1)
[2010-01-28 22:08:20] VERBOSE[13264] logger.c: -- Executing [[email protected]:1] DeadAGI("SIP/DIDx06-00000017", "a2billing.php|1|did") in new stack
[2010-01-28 22:08:20] WARNING[13264] res_agi.c: Running DeadAGI on a live channel will cause problems, please use AGI
[2010-01-28 22:08:20] VERBOSE[13264] logger.c: -- Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
[2010-01-28 22:08:20] VERBOSE[13264] logger.c: -- AGI Script a2billing.php completed, returning 0


Can anyone tell me what's happening here?

Thanks,

Robin


Last edited by RobinA on Sat Feb 06, 2010 5:18 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls
PostPosted: Fri Jan 29, 2010 8:20 am 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Hi

Turn up the verbosity in the output in the agi-conf.

Make sure your DID are enabled and have a valid destination, and that the DID delivered by your carrier matches that in Inbound DID in A2Billing exactly

Joe


Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls
PostPosted: Fri Jan 29, 2010 2:22 pm 
Offline

Joined: Sat May 10, 2008 4:19 pm
Posts: 132
Location: Wilmington, DE
Joe,

Thanks for your reply.
I turned everything up and made sure the DIDs are in place correctly but the result is the same.
Could it be that one or more tables weren't updated properly? I ask because I can see other table related problems.
These same DIDs were working fine in 1.3.4.

Thanks again,

Robin


Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls
PostPosted: Fri Feb 05, 2010 3:39 pm 
Offline

Joined: Sat May 10, 2008 4:19 pm
Posts: 132
Location: Wilmington, DE
Hello All,

I would really appreciate some help here. I turned up A2B's debug to 3 and Asterisk verbosity to 15 and the result is a little different from the first post. (See below)
The DIDs are setup correctly because on a new install it works perfectly but on my upgrade is where the problem is and I cannot go back. I compared the table structure of cc_card, and the cc_did* tables with the new install and they seem fine. Everything else is working fine, just the a2billing-did is killing me. Everything works in FreePBX also.

Again, I would really appreciate some help here. Here is the output.


Code:
-- Executing [[email protected]:1] Answer("SIP/DIDx06-0000003d", "") in new stack
    -- Executing [[email protected]:2] Wait("SIP/DIDx06-0000003d", "1") in new stack
    -- Executing [[email protected]:3] DeadAGI("SIP/DIDx06-0000003d", "a2billing.php|1|did") in new stack
    -- Launched AGI Script /var/lib/asterisk/agi-bin/a2billing.php
  a2billing.php|1|did: file:a2billing.php - line:102 - uniqueid: - IDCONFIG : 1 ::> 3
  a2billing.php|1|did: file:a2billing.php - line:103 - uniqueid: - MODE : did ::> 3
  a2billing.php|1|did: file:Class.A2Billing.php - line:710 - uniqueid:1265384206.64 -  get_agi_request_parameter = 1992186569 ; SIP/DIDx06-0000003d ; 1265384206.64 ;  ; 1XXX8763211 ::> 3
  a2billing.php|1|did: file:a2billing.php - line:367 - uniqueid:1265384206.64 - [ANSWER CALL] ::> 3
  a2billing.php|1|did: file:a2billing.php - line:382 - uniqueid:1265384206.64 - [DID CALL - [CallerID=1992186569]:[DID=1XXX8763211] ::> 3
  a2billing.php|1|did: file:Class.A2Billing.php - line:1229 - uniqueid:1265384206.64 - [A2Billing] DID call friend: FOLLOWME=1 (cardnumber:770XXX9814|destination:SIP/770XXX9814/1XXX8763211/|tariff:3)
  a2billing.php|1|did:  ::> 3
  a2billing.php|1|did: file:Class.A2Billing.php - line:1242 - uniqueid:1265384206.64 - [A2Billing] DID call friend: AUTHENTICATION FAILS !!!
  a2billing.php|1|did:  ::> 3
  a2billing.php|1|did: file:Class.A2Billing.php - line:1229 - uniqueid:1265384206.64 - [A2Billing] DID call friend: FOLLOWME=2 (cardnumber:770XXX9814|destination:19925127742|tariff:3)
  a2billing.php|1|did:  ::> 3
  a2billing.php|1|did: file:Class.A2Billing.php - line:1242 - uniqueid:1265384206.64 - [A2Billing] DID call friend: AUTHENTICATION FAILS !!!
  a2billing.php|1|did:  ::> 3
    -- AGI Script a2billing.php completed, returning 0


Thanks,

Robin


Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls
PostPosted: Sat Feb 06, 2010 12:16 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
try setting the destination as:-

destination:SIP/770XXX9814

where 770XXX9814 is the a2billing account number

Joe


Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls [SOLVED]
PostPosted: Sat Feb 06, 2010 5:43 pm 
Offline

Joined: Sat May 10, 2008 4:19 pm
Posts: 132
Location: Wilmington, DE
Thanks Joe,

I tried that but it didn't work.
The problem was "sip_iax_friends", if that is set to YES in any of the agi-confX, I encounter major problems.
When agi-conf1 was set to yes, the callingcard was using the dnid instead of the destination number entered even though "use_dnid" was set to "no". Now in agi-conf2 I had to use "a2billing-did,2" and "sip_iax_friends" must be set to NO even though this was working fine in 1.3.4.

Thanks again.

Robin.


Top
 Profile  
 
 Post subject: Re: A2B 144 not answering DID calls [SOLVED]
PostPosted: Sat Feb 06, 2010 5:52 pm 
Offline

Joined: Fri Jun 23, 2006 3:56 pm
Posts: 4065
Hi

In 1.4 onwards, sip_iax friend is a bit redundant, as we use the DID for customer to customer calling.

Also, a couple of releases ago, a change was made to deliver the DNID, which is the number that has been used to access the system in say a call through service, rather than previously the dialled digits. which makes more sense, but has had a couple of unexpected side effects.

Joe


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 
Voice Broadcast System


All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group